A-A+

linux-headers-4.3.0-kali1-686-pae 虚拟机tools安装各种错误

2016年03月02日 11:12 学习笔记 评论 3 条 阅读 6,381 views 次

【注意:此文章为博主原创文章!转载需注意,请带原文链接,至少也要是txt格式!】

问题已经解决,首先,去本文章把下面的更新源添加进去,然后更新。。

最重要的一个更新源:

deb http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib

apt-get update

apt-get dist-upgrade # get a coffee, or 10.

然后重启,再然后

apt-get update

apt-get install open-vm-tools-desktop fuse

然后再次重启就OK了。。。。。

 

以上为官网说明:https://www.kali.org/news/kali-linux-rolling-edition-2016-1/

 

 

 

------------------下面为以前手记无需观看---------------------------------

 

 

 

 

先做一个笔记,此问题未解决完毕。。。。

E: 无法定位软件包 linux-headers-4.3.0-kali1-686-pae

E: 无法按照 glob ‘linux-headers-4.3.0-kali1-686-pae’ 找到任何软件包

E: 无法按照正则表达式 linux-headers-4.3.0-kali1-686-pae 找到任何软件包

首先打开shell,我们要增加一个源。

vim /etc/apt/sources.list

nano /etc/apt/sources.list

我个人还是比较喜欢nano,因为记忆力拙计。
增加下面两行:

#阿里云kali源
deb http://mirrors.aliyun.com/kali sana main non-free contrib
deb-src http://mirrors.aliyun.com/kali sana main non-free contrib
deb http://mirrors.aliyun.com/kali-security sana/updates main contrib non-free
deb-src http://mirrors.aliyun.com/kali-security sana/updates main contrib non-free

#中科大kali源
deb http://mirrors.ustc.edu.cn/kali sana main non-free contrib
deb-src http://mirrors.ustc.edu.cn/kali sana main non-free contrib
deb http://mirrors.ustc.edu.cn/kali-security sana/updates main contrib non-free
deb-src http://mirrors.ustc.edu.cn/kali-security sana/updates main contrib non-free

 

或者官方源:
deb http://http.kali.org/kali sana main non-free contrib
deb-src http://http.kali.org/kali sana main non-free contrib
deb http://security.kali.org/kali-security sana/updates main contrib non-free
deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

 

apt-get update & apt-get upgrade
apt-get dist-upgrade
apt-get clean
更新完毕后,开始安装linux-header:

不要简单的以为更新完就算完事了?!
apt-get install gcc make linux-headers-$(uname -r)
这里因为不同的debian内核版本可能不同,所以用一个uname -r 命令来求出版本进行安装。
问题就出在这里了。。。。 更新内核的时候这个地方提示出错:linux-headers-4.3.0-kali1-686-pae 结果我本人各种寻找答案。。百度是白鸡巴废了。最终谷歌找到了一丝丝答案。
参考文章:http://kali2.mirror.garr.it/1/kali/dists/kali-dev-only/main/binary-i386/Packages 中提示:

Package: linux-headers-4.3.0-kali1-686-pae
Source: linux
Version: 4.3.5-1kali1
Architecture: i386
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Installed-Size: 4276
Depends: linux-headers-4.3.0-kali1-common (= 4.3.5-1kali1), linux-kbuild-4.3, linux-compiler-gcc-5-x86
Homepage: https://www.kernel.org/
Priority: optional
Section: kernel
Filename: pool/main/l/linux/linux-headers-4.3.0-kali1-686-pae_4.3.5-1kali1_i386.deb
Size: 480930
SHA256: bd4c7a5c214a9d0d8cfe1cf5d3b5073d35fc5f25d896d2bd2b2f6b11402ba12b
SHA1: 0e8e9380207b8588cb4f2f41460f8409441a3056
MD5sum: abf0040f2f9af04565c56b860fcbbd39
Description: Header files for Linux 4.3.0-kali1-686-pae
This package provides the architecture-specific kernel header files for
Linux kernel 4.3.0-kali1-686-pae, generally used for building out-of-tree
kernel modules. These files are going to be installed into
/usr/src/linux-headers-4.3.0-kali1-686-pae, and can be used for building
modules that load into the kernel provided by the
linux-image-4.3.0-kali1-686-pae package.

然后本人一顿努力寻找。终于找到这个源文件包。
http://http.kali.org/kali/pool/main/l/linux/ 在这里下载,具体的下载地址:http://http.kali.org/kali/pool/main/l/linux/linux-headers-4.3.0-kali1-686-pae_4.3.5-1kali1_i386.deb
本以为下载后可以更新,结果又TM提示错误!!!缺少各种包。。。然后缺少的东西都可以在这个网站上下载。

正在选中未选择的软件包 linux-headers-4.3.0-kali1-686-pae。
(正在读取数据库 ... 系统当前共安装有 299455 个文件和目录。)
正准备解包 linux-headers-4.3.0-kali1-686-pae_4.3.3-5kali4_i386.deb  ...
正在解包 linux-headers-4.3.0-kali1-686-pae (4.3.3-5kali4) ...
dpkg: 依赖关系问题使得 linux-headers-4.3.0-kali1-686-pae 的配置工作不能继续:
linux-headers-4.3.0-kali1-686-pae 依赖于 linux-headers-4.3.0-kali1-common (= 4.3.3-5kali4);然而:
未安装软件包 linux-headers-4.3.0-kali1-common。
linux-headers-4.3.0-kali1-686-pae 依赖于 linux-kbuild-4.3;然而:
未安装软件包 linux-kbuild-4.3。
linux-headers-4.3.0-kali1-686-pae 依赖于 linux-compiler-gcc-5-x86;然而:
未安装软件包 linux-compiler-gcc-5-x86。

dpkg: 处理软件包 linux-headers-4.3.0-kali1-686-pae (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-headers-4.3.0-kali1-686-pae

 

安装DEB文件的命令:dpkg -i xxxxxx.deb

唯独有一个包下载地址这里没有,名字是:linux-kbuild-4.3
SO,又是一顿谷歌,最终找到下载地址:https://packages.debian.org/sid/i386/linux-kbuild-4.3/download 看清哦,是I386的。。。。
然后下面的安装步骤:
cd vmware-tools-distrib/
./vmware-tools-install.pl
别以为一顿回车最终出现
To make use of the virtual printer, you will need to restart the CUPS service
Enjoy
你以为成功了?》! 失败才刚刚开始。。。跟本没安装成功,我翻看记录发现各种地方各种错误!!!!!!!哭都没地方哭。。。真TM闹听。。。所以暂时记录到这里。待定。。。。

------------------------error code-------------------------------

 

Searching for a valid kernel header path...
Detected the kernel headers at
"/lib/modules/4.3.0-kali1-686-pae/build/include".
The path "/lib/modules/4.3.0-kali1-686-pae/build/include" appears to be a valid
path to the 4.3.0-kali1-686-pae kernel headers.
Would you like to change it? [no]

make: Entering directory '/tmp/modconfig-FZpmhZ/vmhgfs-only'
Using 2.6.x kernel build system.
/usr/bin/make -C /lib/modules/4.3.0-kali1-686-pae/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
MODULEBUILDDIR= modules
make[1]: Entering directory '/usr/src/linux-headers-4.3.0-kali1-686-pae'
Makefile:10: *** mixed implicit and normal rules: deprecated syntax
CC [M]  /tmp/modconfig-FZpmhZ/vmhgfs-only/message.o
CC [M]  /tmp/modconfig-FZpmhZ/vmhgfs-only/dir.o
In file included from /tmp/modconfig-FZpmhZ/vmhgfs-only/backdoor.h:30:0,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/message.c:54:
/tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/vm_assert.h:259:0: warning: "DEPRECATED" redefined
#define DEPRECATED(_fix) do {} while (0)
^
In file included from /usr/src/linux-headers-4.3.0-kali1-common/include/linux/kernel.h:13:0,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/kernelStubs.h:36,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/message.c:45:
/usr/src/linux-headers-4.3.0-kali1-common/include/linux/printk.h:105:0: note: this is the location of the previous definition
#define DEPRECATED "[Deprecated]: "
^
CC [M]  /tmp/modconfig-FZpmhZ/vmhgfs-only/rpcout.o
In file included from /tmp/modconfig-FZpmhZ/vmhgfs-only/hgfs.h:40:0,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/hgfsProto.h:37,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:37:
/tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/vm_assert.h:259:0: warning: "DEPRECATED" redefined
#define DEPRECATED(_fix) do {} while (0)
^
In file included from /usr/src/linux-headers-4.3.0-kali1-common/include/linux/kernel.h:13:0,
from /usr/src/linux-headers-4.3.0-kali1-common/include/linux/list.h:8,
from /usr/src/linux-headers-4.3.0-kali1-common/include/linux/module.h:9,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:29:
/usr/src/linux-headers-4.3.0-kali1-common/include/linux/printk.h:105:0: note: this is the location of the previous definition
#define DEPRECATED "[Deprecated]: "
^
In file included from /tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/vmware.h:39:0,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/rpcout.c:43:
/tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/vm_assert.h:259:0: warning: "DEPRECATED" redefined
#define DEPRECATED(_fix) do {} while (0)
^
In file included from /usr/src/linux-headers-4.3.0-kali1-common/include/linux/kernel.h:13:0,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/kernelStubs.h:36,
from /tmp/modconfig-FZpmhZ/vmhgfs-only/rpcout.c:33:
/usr/src/linux-headers-4.3.0-kali1-common/include/linux/printk.h:105:0: note: this is the location of the previous definition
#define DEPRECATED "[Deprecated]: "
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c: In function ‘HgfsPackDirOpenRequest’:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:417:26: error: ‘struct file’ has no member named ‘f_dentry’
file->f_dentry) < 0) {
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c: In function ‘HgfsDirLlseek’:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:707:32: error: ‘struct file’ has no member named ‘f_dentry’
struct dentry *dentry = file->f_dentry;
^
In file included from /tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:39:0:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c: In function ‘HgfsReaddirNextEntry’:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:993:31: error: ‘struct file’ has no member named ‘f_dentry’
si = HGFS_SB_TO_COMMON(file->f_dentry->d_inode->i_sb);
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/module.h:89:62: note: in definition of macro ‘HGFS_SB_TO_COMMON’
#define HGFS_SB_TO_COMMON(sb)             ((HgfsSuperInfo *)(sb)->s_fs_info)
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:1082:26: error: ‘struct file’ has no member named ‘f_dentry’
*entryIno = file->f_dentry->d_inode->i_ino;
^
In file included from /tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:30:0:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:1088:44: error: ‘struct file’ has no member named ‘f_dentry’
*entryIno = compat_parent_ino(file->f_dentry);
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/./shared/compat_fs.h:120:46: note: in definition of macro ‘compat_parent_ino’
#define compat_parent_ino(dentry) parent_ino(dentry)
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:1093:52: error: ‘struct file’ has no member named ‘f_dentry’
*entryIno = HgfsGetFileInode(&entryAttrs, file->f_dentry->d_inode->i_sb);
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c: In function ‘HgfsDoReaddir’:
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:1173:13: error: ‘struct file’ has no member named ‘f_dentry’
!(file->f_dentry) ||
^
/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.c:1174:13: error: ‘struct file’ has no member named ‘f_dentry’
!(file->f_dentry->d_inode)) {
^
/usr/src/linux-headers-4.3.0-kali1-common/scripts/Makefile.build:263: recipe for target '/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.o' failed
make[4]: *** [/tmp/modconfig-FZpmhZ/vmhgfs-only/dir.o] Error 1
make[4]: *** 正在等待未完成的任务....
/usr/src/linux-headers-4.3.0-kali1-common/Makefile:1395: recipe for target '_module_/tmp/modconfig-FZpmhZ/vmhgfs-only' failed
make[3]: *** [_module_/tmp/modconfig-FZpmhZ/vmhgfs-only] Error 2
Makefile:146: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.3.0-kali1-686-pae'
Makefile:130: recipe for target 'vmhgfs.ko' failed
make: *** [vmhgfs.ko] Error 2
make: Leaving directory '/tmp/modconfig-FZpmhZ/vmhgfs-only'

The filesystem driver (vmhgfs module) is used only for the shared folder
feature. The rest of the software provided by VMware Tools is designed to work
independently of this feature.

 

 

卸载东西命令

sudo apt-get remove --purge 包名
sudo apt-get autoremove

标签:

3 条留言  访客:2 条  博主:1 条

  1. gdd

    正在卸载 fonts-droid (1:4.4.4r2-7) …
    正在卸载 libqt5xcbqpa5:i386 (5.5.1+dfsg-12) …
    dpkg: libwebkitgtk-1.0-common:有依赖问题,但是如您所愿,将继续卸载:
    libwebkitgtk-1.0-0:i386 依赖于 libwebkitgtk-1.0-common (>= 2.4.9);然而:
    即将删除 libwebkitgtk-1.0-common。

    正在卸载 libwebkitgtk-1.0-common (2.4.9-3) …
    正在处理用于 fontconfig (2.11.0-6.3) 的触发器 …
    正在处理用于 libc-bin (2.22-4) 的触发器 …

  2. 尝试到现在

    从下午开始一直寻找方法,就你的好使!太感谢了!

  3. Chou ke

    请问下linux-compiler-gcc-5-x86 安装成功了沒, 25/5000過程可以分享下嗎
    thank thank thank

给我留言